adrian: July 2011 Archives

After having sent my 7D in to Canon Canada 5 times now, and having them tell me every single time that there is no issue with the camera, and that this is the first they've ever heard of an AF issue with some subset of 7Ds, I've decided to start tracking all of the problem threads and people who both have experienced this issue and returned a camera to Canon service anywhere in the world for it.

My camera had a very real front-focusing AF issue as evidenced by this side-by-side comparison image, using centre-point, one shot, single point AF:

I could shoot the same tree from 10 feet all day and end up with the same out of focus image.

The second body, a loaner 7D from the CPS pool produced the second image using the same lens, on a tripod, in very bright daylight. (ISO 100, f/1.2, 1/2500s).

At least in Canada, there is only one product specialist for the 7D in Mississauga it seems, so if more than one person has sent a 7D in for this problem, and probably more than once, it would suggest that Canon knows more than they are saying.

If you've had AF-related issues with your 7D and have a case to make, please sign the petition

This issue seems to affect a small number of 7Ds, so the assumption is most work absolutely fine. If yours works great, and you've never had an issue, happy shooting, but I'm mostly interested in people who have similar issues and have also sent their camera in to Canon service.

If there are enough people who report similar issues I will try and come up with a better way to organize and track this data.

| | Comments () | TrackBacks (0)